[Librecmc-users] Another Upgrade Failure

Robert Call bob at librecmc.org
Wed Apr 11 17:43:14 EDT 2018


On Wed, 2018-04-11 at 15:52 -0400, Michael Vincent wrote:
> Hi,
> 
> It seems like I've soft-bricked my ThinkPenguin TPE-R1100 router
> while trying to upgrade LibreCMC on it, and now I can't get it
> working again. I have contacted ThinkPenguin support, but so far they
> haven't suggested anything I haven't already tried.
> 
> The problems I encountered were very similar to those described by
> Simon Lydell in the recent thread called "Tried to upgrade my router
> and failed :(" . I upgraded LibreCMC from 1.4.1 to 1.4.2, and then
> again to 1.4.3. I'm pretty sure I foolishly overlooked the "uncheck
> keep settings" step, though. Once things stopped working right, I
> tried to do a full reset of the router, but it just made things
> worse. The status lights on the router are, from left to right,
> green, off, and red.
> 
> I tried following the advice that worked for Simon; unfortunately,
> Christopher Howard's suggested commands to fix dnsmaq didn't work for
> me. I somehow eventually managed to get an internet connection back,
> but now I'm stuck. 
> 
> Like Simon, my main problem is that I can't connect to the LuCI
> interface. I seem to only be able to connect to the internet via IPv6
> connections. I can connect to the router via ssh (at first using the
> link-local address, but then I noticed that just using 192.168.10.1
> worked). I've repeatedly tried the 'firstboot' command, but it never
> fixes the problem. 
> 
> I note that uhttpd does not show up in the output of 'ps', and ls -lh
> /www returns nothing. 
> Below are the outputs of a couple other commands that were requested
> of Simon. (I originally tried sending this with the log file
> appended, but it didn't go through since the message size was too
> big. I will try sending it as a response to this message.)

First I'd like to note that it does take a about 1 minute for the first
boot since it has to generate new keys and erase the last bit of flash
(after a firstboot). 

Did you flash the correct image? It sounds like you flashed a core
image to the router (which does not include luci).

Also (in regards to another message sent), the only difference between
libreCMC images and the ones that ThinkPenguin ships are the inclusion
of the openvpn-openssl package.

--
Robert Call (Bob)
bob at librecmc.org
https://librecmc.org



More information about the Librecmc-users mailing list